Performance Degradation

Incident Report for desk.ly

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 09:32 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 09:19 CEST

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 08:54 CEST

Investigating

We are currently investigating an issue causing degraded performance across parts of the desk.ly platform.

Some users may experience slower response times or intermittent timeouts.

Our team is actively working to identify the root cause and restore normal performance.

We will provide an update within the next 60 minutes.
Posted Apr 13, 2026 - 08:40 CEST
This incident affected: WebApp, Smartphone Apps, MS Teams App, and HR Synchronization.