Book in App reloads
Incident Report for desk.ly
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 10:08 CET
Investigating
We are currently investigating this issue. Please use the web app to book your seats.

Sorry for the inconvenience caused.
Posted Nov 29, 2022 - 22:07 CET
This incident affected: Smartphone Apps.